Take the 2-minute tour ×
LEGO® Answers is a question and answer site for LEGO® and building block enthusiasts. It's 100% free, no registration required.

I have an RCX 1.0 set from 1998 and I would like to upgrade the RCX 1.0 to RCX 2.0. Can this be done? Exactly how would I obtain a firmware file and load it? I do have access to the Bricxx Command Center, if required.

share|improve this question
1  
Not a definitive answer, but I really doubt the hardware is similar enough 10+ years later that you can just re-flash some firmware. –  Aaron D. Marasco Jul 26 '12 at 0:50
1  
Actually, it's the exact same hardware. –  Joubarc Jul 26 '12 at 6:26
add comment

1 Answer 1

The hardware of RCX 2.0 is identical to 1.5, and the only difference between these two and version 1.0 is the charging port which had been removed. So they're compatible and you can indeed use a newer firmware on an older brick.

You'll need the Mindstorms 2.5 SDK, which contains the latest official firmware. It's probably not on the LEGO site any more, but Philo has saved it for posterity on his site.

You may also want to use a compatible, but faster, firwmare from Dick Swan, you'll find it archived here.

As for uploading it to the RCX brick, I think there's indeed an option for it in BrickCC but I'm not too sure where, so I can't help much there. It's probably in the documentation somewhere.

share|improve this answer
2  
I confirm that Bricxcc can upload firmware to the RCX (in tools menu) –  Philo Jul 30 '12 at 9:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.