Take the 2-minute tour ×
LEGO® Answers is a question and answer site for LEGO® and building block enthusiasts. It's 100% free, no registration required.

I think I have a defective NXT brick. It has been programmed to move in a direction for 1 second, wait 1 second and then move in the reverse direction for 1 second. The code downloads on another brick and works fine. I have tried changing the battery pack, changing the motor, changing laptops, changing usb cords, cables, etc. and bricks. The problem has been isolated to the brick. I tried a soft reset and ultimately a hard reset with new firmware download and nothing works. I am truly perplexed. I am using Windows 7 and also tried it on XP. The motor will run in one direction. It starts off slow, speeds up, pauses, and then goes faster. When I turn the brick on, the motor runs briefly before the NXT chirp sound comes up. Yes it is plugged into the correct motor port.

share|improve this question
    
Since you've thoroughly narrowed it down to the brick itself, you'd probably be safer to contact the LEGO customer service to ask for a replacement –  Joubarc Jul 19 '13 at 16:35

1 Answer 1

Looks like it might be a defective motor driver chip (though they are pretty tough!). What happens if you connect the motor on another port of the same brick? (with program change to reflect port modification)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.