LEGO® Answers is a question and answer site for LEGO® and building block enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running 6 NXT robots in an introductory class. Occasionally we've had bricks that would not accept a program and I've reset the brick by pushing the reset button under the battery pack as well as pushing the button under the USB port, experiencing the blank screen and "click..." Re installing the firmware usually gets them going again. I have one brick that when cleared and reset will accept a download, but when the program is run, port B drives the motor at full speed, and nothing else happens. I have reset the brick many times, and the problem still exists. I sent a query to LEGO and got a computer generated response that there would be contact in 1-2 days.... nothing after a week, Sent the same query again and got tho same auto response.... still no real contact (after 4 days) I'm looking for suggestions. Thanks!

share|improve this question
"click, click ..." is a sign the firmware has gone bad or has never been installed. So replacing the firmware is the only option. "Port B motor drives at full speed." Does anything else work? LCD panel visible? Can you download programs? Any chance the Port B wiring connection has crossed up wires? If the LCD panel is visible, there are a set of menu options to View the Rotation sensor on Port B. Does that change when the Port B motor is turned by hand? – dfrevert Dec 6 '13 at 19:24
Receiving no response from the customer service seems unusal as these guys usually have an excellent track record of helping customers. You may want to try calling them directly using the free number for your country. Let them know that you never received a response to your two queries, this may give them the chance to fix what went wrong there. – Joubarc Jan 16 '14 at 8:21

I think the solution suggested at will help you.

share|improve this answer
Rex implied he tried that multiple times already – Joubarc Jan 16 '14 at 8:28
Also we prefer longer answers to links to other posts. If you could summarise the solution and link back that would be appreciated. – Zhaph - Ben Duguid Feb 10 '14 at 7:43

Since you tried reuploading the firwmare without success, it sounds like the brick is indeed defective. You were right to contact the customer service in that case as they should be able to replace it; however it's not normal that they didn't contact you back. You may want to call them directly (you can find the number on the service web page) and let them know that your online queries went unanswered.

Alternatively, if you got Education kits (which seems likely since it's for a class), you may want to contact your reseller first and let them know aoub the issue.

The only other possible thing I could imagine going wrong is that the firmware file is corrupted somehow - this would be consistent with the brick accepting it for download, but then failing to run properly. If you have another brick, you may want to try to send the same firmware to it and see if the problem happens too. Then of course you'd need to make sure you download the latest firmware and try that one - I woudl say it's worth a shot anyway (you could also redownload and compare with your existing file if you want to check it's corrupted or not).

share|improve this answer

I managed to recover a 'clicking' NXT brick using a PC with windows XP and Lego Mindstorm NXT v2.0 just by clicking on Update NXT Firmware .

share|improve this answer
Cheers dino, and welcome to LEGO Answers. Sadly Rex states that he's already tried re-installing the firmware on the Brick in question with no luck. – Zhaph - Ben Duguid Nov 4 '14 at 9:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.