I am using the Lego Mindstorms NXT Education Kit, software version 2.1. Everything was working fine writing programs and downloading them to the robot until all of a sudden when I tried downloading a program to the robot, I would get the following error:

Error:1003 The required file is broken

Here is a list of things I have tried with no success:

  • Ensuring the robot is turned on
  • Ensuring the USB cable is properly connected
  • Restarting the Mindstorms software
  • Restarting the Computer
  • Restarting the robot
  • Updating the firmware on the NXT (which had the unfortunate side effect of deleting every file on it!)

After I got this error when trying to download one file, I am now getting this error when I try to download any file onto the NXT. It even occurs with very simple files (just one move block).

None of the files have any MyBlocks.

6 Answers 6


As documented in this First Lego League forum post, this problem can be solved by installing the NXT EDU 2.1f3 patch.

A cached direct link to the patch can be obtained here. The patch is for both Windows and OSX.

  • 1
    I found the link to download the NXT EDU 2.1f3 patch, the original one was broken. Download here for windows. Commented May 23, 2013 at 4:34

I just installed the retail version of NXT 2.0 (v2.0f6) on Mac OS 10.5.8 and got the error 1003 "a required file is broken" when first starting up the Mindstorms NXT application. Turns out this is a known bug when using the case-sensitive journaled filesystem. Mindstorm tech support walked me through the fix which was to rename the "/Library/Frameworks/Fantom.framework" directory to "/Library/Frameworks/fantom.framework". (The only change is the 'f' in "Fantom.framework".)

  • Last one helped: run console, sudo su and mv Fantom.framework/ fantom.framework
    – user2467
    Commented Apr 2, 2013 at 21:03

I ran into this issue using macos 10.8 on some new macbook airs and trying to run Mindstorms NXT for Education software, tried various 2.0 and 2.1 versions.

We eventually got a ~900meg NXT 2.1f installer package from Lego support,

If you popped up the mac console application, you would see various framework/library errors related to Fantom.framework and VISA.framework. Running the uninstallers for the old versions and reinstalling newest versions of both NXT and the Lego Driver (Fantom driver) did not work, nor did applying patches/updates to older versions.

It turned out the problem had to do with the fantom driver and the VISA.framework never being fully uninstalled/being messed up from the old versions. I went to a terminal, sudo'ed bash (to get a root shell), and deleted all of these ( i.e. rm -rf /Libraries/Frameworks/Fantom.framework and then rm -rf /Libraries/Frameworks/VISA.framework)

Here is my recipe for fixing this/getting

  1. Uninstall any old/other versions of NXT via running the uninstall.sh script as root/sudo from a terminal (this script is under the NXT application directory)

  2. Install the latest NXT edu 2.1f from the large (~900meg) zip file that Lego support sent us (sorry, I don't have a download link)

  3. Delete the /Library/Frameworks/Fantom.framework and /Library/Frameworks/Visa.framework directories completely (VISA or something, I might not have the full name spelled correctly but it is something like that)

  4. From the “parts” folder inside the NXT installation folder (after you unpack it), run the legodriver.pkg installer – this will put in the new/working versions of LISA and Fantom framework


I installed Mindstorm Education Kit 2.1 on a 2009 Mac Book Pro 17" running Mac OS X 10.8.1 (Mountain Lion) and received the 1003 Error code on launch. I was able to eliminate the error by installing the Fantom Driver.


You need to download the latest patch for NXT EDU.


Uninstalling Flash Player fixed the issue for me (OSX 10.8.5). It was a tip I saw the lego message boards.

Not the answer you're looking for? Browse other questions tagged or ask your own question.