Using Mindstorms education 2.0 on a Windows 7 computer I can't seem to get the program to see the NXT via USB or bluetooth dongle.

When connected by USB nothing appears in the NXT window with device turned on. When downloading a program, error code: -142023 is thrown. Cannot connect to NXT device

When connected by bluetooth the NXT device shows in the NXT window as available until I try the connect button. The standard serial over bluetooth is created and a COM is opened but then the error code: -142023 is displayed. Cannot connect to the NXT device

Other things I have tried:

  • NXT works with multiple cords on other computers but not on one other windows 7
  • Computer security settings have been decreased to allow devices to talk to programs
  • removing and reloading program
  • 2
    Have you tried running the Mindstorms application in Compatibility Mode? Right-click on the shortcut, and click into the "Compatibility" tab, and set it to run as Windows XP (Service Pack 3). – Zhaph - Ben Duguid Feb 2 '12 at 9:29
  • I'll add it as an answer for you to accept then ;) – Zhaph - Ben Duguid Feb 4 '12 at 9:38

I believe that you need to run the Mindstorms Education program in Compatability mode.

The easiest way to do this is to:

  1. Right click on the Mindstorms shortcut on either your start menu or desktop and select "Properties".
  2. Switch to the "Compatability" tab.
  3. Check the "Run in Compatability mode", and from the drop down that is then enabled select "Windows XP (Service Pack 3)".
  4. Ok out of the dialog.

That should solve your problem.

| improve this answer | |
  • I tried the above but still couldn't make Bluetooth connect on a Win7-32 laptop, although the connection was working fine to a Mac (I would have stayed with the Mac but wanted to use Robot-C which is PC only). The error was -142016, I think. I then tried a connection with the USB cable (which worked); after that the Bluetooth connection also worked. It didn't need compatibility mode settings. – quilkin Dec 27 '12 at 18:12
  • didn't work for me had the same problem...........d – user6044 Aug 6 '15 at 16:47
  • If you have any further details of what you're running, and what sort of errors you're getting we might be able to help further? – Zhaph - Ben Duguid Aug 10 '15 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.