I hope someone can help me with a problem with getting an original RCX 1.0 system working with a current PC.

I bought the RCX 1.0 system back in (I think) 2000 but its been in storage a long time. In the meantime I had children, and now one of them is curious about it and I want to encourage that.

The brick powers-up ok, but the RIS software won't install on my laptop (Win7 x64) and the laptop has no serial port to plug the IR tower into. To work around this I created a Windows XP virtual machine (in VMware Workstation), installed the RCS software on the VM, connected the IR tower to the laptop with an USB-to-serial converter, and bridged the USB port to the VM. This kind of works, in that the RIS software can recognise the RCX brick. However, it says that the firmware is missing and needs to be downloaded. When I do this I repeatedly get a download error.

Update 1: The RIS software displays the message "Initializing and downloading firmware", the LCD on the RCX counts from 0 to 20 ten times, and then the RIS software displays the error "RCX firmware failed to download". I think its trying to download from the PC to the RCS, not from the internet - if I disable the VMs network connection the it fails in exactly the same way and netstat isn't showing any network connection attempts inside the VM.

Has anyone here got a similar setup to work, or has any thoughts on what might be going wrong? Are there any command-line or diagnostic tools I could use to interrogate the RCX and/or upload the firmware outside of the RIS environment?

I'm tempted to just buy an NXT, which will be compatible with modern hardware, but I don't feel ready to give up just yet.

Update 2: I ran a USB sniffer in the VM to view the data being sent over the usb-to-serial connector. Lots of binary data being sent to the serial tower, and some patterns that suggest message framing in an application-level protocol, but nothing I could understand that indicates an error condition. The problem is not at the level of the usb adapter though.

Update 3: In the end I found an old PC with a serial port and the RCX worked without a problem. The RIS software installs and works okay on Windows XP SP2. My thanks to those who contributed suggestions.

  • The problem could also be that the lego RIS software doesn't actually always support Windows XP. RIS 1 / 1.5 was always a Windows 9x product that used a serial port for the IR tower and therefore didn't even need a Windows driver, yet it seems they went out of their way to make sure it did not work on Windows NT/2000. RIS 2.0 with the USB tower is for 98/ME but claims to work on "a beta version of XP" but it's not officially supported by Lego and no attempt was ever made for Win 2000 support. So maybe a Win 98 would be a better choice for anyone looking to run a VM for RIS. Commented Sep 30, 2021 at 14:36

6 Answers 6


This did the trick for me. My situation mirrors the original poster.


There are 4 parts to this. BrickControlCenter (brickcc), a driver for the IR tower, an image of the firmware and some other piece of software called the NCQ.

I did not install the driver since I was using a USB to RS232 adapter and BrickCC worked just fine installing the firmware.

Added bonus, the brickCC is a full on IDE for the RCX.

Also, Swap memory has to be set to at least 4GB because of some limitation on Director 6 which causes the MindStorm program to stall sometimes as it determined that it's 3MB requirement is greater than the available gigabytes if they're 3GB or less. Clever.

  • Great. Finally I managed to download the firmware to RCX 1.0
    – toesslab
    Commented Aug 29, 2015 at 6:36

LEGO Mindstorms was initially released in 1998, running on Windows 95/98, and Windows 2000 and XP were not supported let alone Windows 7.

I know that they did release an updated install CD for the Mindstorms Vision Kit which allowed you to install it on Windows XP (I believe I've still got a copy of this somewhere), however you may be able to install the software and get it running directly under Windows 7 using Compatibility mode - which I know has worked for the Mindstorms Education software (so even switching to NXT won't solve all your pain).

  • 2
    thanks for responding. Thanks for the pointers on compatibility. I hadn't appreciated just how old this h/w is. I chose XP because it was (as far as I know) the first version of windows with good built-in usb support. I'll try using the XP compatibility mode feature, which I'd also forgotten about. (I've tried installing the s/w under Win7 but that didn't work even when I tweaked the compatibility settings). Commented Feb 7, 2012 at 22:07
  • True. I remember taking the Serial version back for a refund because I couldn't get it to work reliably with my PC, then bought the 2.0 USB based version a year or so later. Commented Feb 7, 2012 at 22:10

Just went through this exercise on a Windows 10 64 BIT PC. RCX 1.0 w/ serial IR transmitter. I am able to get the RIS software running w/o issue on Windows 10 via compatibility mode (256 color, Win 98, etc). IR port even detects and turns on in the start up tutorial but as described above, initial download of FW clocks the RCX from 1 to 20 several times before failing. Gave up on this, set up a WinXP VM, and everything works via that.


How about running Windows 98 on a Raspberry Pi device and using the Lego IR USB tower that way?

Here is a tutorial on running Windows 98 on a Raspberry Pi.


I found this, too: https://minordiscoveries.wordpress.com/2014/01/20/using-nqc-on-a-raspberry-pi-to-program-a-lego-mindstorms-rcx-brick/


I have a similar problem with my RCX 1.0. Also have a RCX 2.0 that loads the firmware just fine. After failing to load more up to date firmware I tried loading the original RCX 1.0 firmware from the original CD with a third party tool (ROBOTC) and got a checksum error. My RCX 1.0 has a hard time getting a signal from the USB IR tower that came with the 2.0 kit. So I am suspecting the transmission is faulty. Unfortunately I don't have the original serial IR transmitter to test it with that one.

Although I have the RCX 2.0 I'd like to get the 1.0 going as well because it comes with a power cord. Nice to have for stationary robots. According to everything I read the 1.0 line should be compatible with the 2.0 kit - so I am not sure if mine is maybe defective.

It seemed in working condition before I tried the firmware update i.e. still had old programs on there that executed.


The RCX system is fairly old technology which LEGO no longer supports. When you're prompted to download firmware, the download error would be due to LEGO no longer hosting the firmware download.

There are plenty more firmware downloads from 3rd party developers for the RCX, although they may no longer be supported.

If you're not so interested in the more advanced functionality and the learning curve that comes with it, you may want to invest in a EV3 which is the most current Mindstorms system.

  • 2
    thanks for responding. I've added some more details of the error. When the RIS software says its downlaoding firmware, I think it means downloading from the PC to the RCX, not from the net. Thanks for reminding me about the alternative firmware - I'd forgotten all about them. My reason for persisting with the combination of stock firmware and RIS environment is that I think the RIS visual programming language would be easier for my 7yr old to understand. As a developer I'm happy with C or Java based alternatives, but he would struggle! Commented Feb 7, 2012 at 21:59
  • 3
    Even if you plan to use the regular LEGO firmware, you can upload it to the RCX using third-party utilities. Bricxcc has a page of utilities which can probably help you there. At least you should be able to assert whether the brick itself may be defective or not.
    – Joubarc
    Commented Feb 16, 2012 at 10:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.