Just two weeks ago, my kid got a 60198 cargo train and we added a set of 60238 switching tracks. With two (out of three) switches we have the problem that the switch doesn't close properly anymore to perform the lane change (the position to go straight is fine). As you can see the movable rail part doesn't completely close against the fixed rail track, causing the wheels to miss the turn. The train either just goes straight (best case) or de-rails (worst-case).

switch doesn't close

Any idea what the cause is, and is there anything I can do to fix this? This happened with two different sets, bought about 5 months apart (but put in use at same time) with two different vendors across Europe, so I'd be surprised this to be a 'bad batch'. I've also tried reversing the locomotive to check it isn't because the wheels are misaligned, but both the powered and non-powered wheels give the same result. On first sight it looks like there is a spring in the switch which got stuck/compressed/..., but I have no idea how to open this without breaking the track.

The correct "go straight" switch position is:

Correct open switch

  • I'd look at the underside of the switch, to see if there is any mechanical blockage of the moving parts.
    – zovits
    Commented Apr 6, 2019 at 8:18

2 Answers 2


Warning: LEGO pieces were harmed for this answer

How the switch works

  • So, how does it work then? Well, let's open it up!

The back plate is held into place by 14 pins. We'll carefully pry it open with a knife. Alternatively, we could use a drill bit to slowly scrape off the pinheads.

Both methods are destructive. The back plate needs to be glued back on later.

Once we can lift off the backplate, we already got the slider.

Next we'll unplug the switch. Let's take a pair of pliers and carefully -just a bit!- squeeze the peg, then push it out.

enter image description here

  • Yellow: The slider is of a soft plastic. Notice the oval hole with a nose. When you move the slider this bit gets squeezed and then snaps into position. There's two stops, they have a figure 8 shape.
  • Red: At the end of the slider there's a single tooth. This tooth flicks the switch.
  • Green: The switch has a peg and a spring. The spring has two legs.
  • The tooth is supposed to sit right between them.

What's next?

So much for starters. Now, what about your points?

In any case, use some compressed air first. Switch them repeatedly. Maybe it's just a grain of dust. Still not functioning properly? Can you still return them?

Okay. Let's triple troubleshoot:

  • Is the slider stuck?
  • Can it move freely? Does it 'snap in'?
  • Does the spring have enough tension?

If the slider's malfunctioning, you'd have to remove the back plate. However, if the spring's your suspect there's a less destructive way.

How to access the peg only

  • In theory, one could try to pry out the switch with a flat screwdriver. I didn't dare it. Parts could warp, the peg could break and I think LEGO did their best to prevent creative kids from doing it.

But take a look at the back plate. You can barely see it, but there's a circle. It's right on top of the peg.

enter image description here

enter image description here

I took a drill bit and started to slowly scratch off some of the plastic. Once the tip was through, I finished off the rest with a scalpel.

Take your time! The plastic is quite thin and the peg's right under it.

I could now easily access the peg with my pliers and push it out. I adjusted the spring and lined everything up.

How to access the spring

This might also work, but I don't recommend it. I gave it a try. It's way too fiddly.

enter image description here

Take a scalpel and cut a hole in the side of the switch. Now you can take a peek inside. See if the tooth is off-center. If so, try to lift the corresponding leg of the spring with a needle. Good luck.

  • 1
    Wow, that is a thorough analysis, illustrated with great pictures and, combined with the sacrifice of the switch, the upvote is more than deserved!
    – zovits
    Commented Apr 15, 2019 at 8:03
  • 3
    @zovits Thanks! Now that we know the hidden parts and how they work, somebody might come up with a less invasive (i.e. destructive) idea. After all, how pointless are points that aren't switching...!
    – Uli
    Commented Apr 15, 2019 at 10:25

Okay, this post is closing in 2 years old, but I have found it looking for a solution to my problem, so others may find it too. I found out two important things:

  1. You don't need to cut or drill the switch to get to the offending spring. You can lift the pivot peg out getting at it from the top.
  2. If the spring is FUBAR or missing, you can actually 3D print it. Full story here: https://www.biasedlogic.com/index.php/fixing-lego-railroad-switches/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.