0

Same problem with both the native 9-pin serial port and with a USB to 9-pin Serial adapter. Using Lego's original cable.

  1. Start BricxCC Version 3.3 (Build 3.3.8.10). It asks for the connection method.

  2. Choose any option for the Port (I've tried them all with the same results), and RCX or RCX2 for the Brick Type. Standard Firmware.
    (Actually, there isn't any firmware in the brick yet. Need to do that as soon as it connects, but I can't even get that far.)

  3. Click OK. Communication fails immediately. "No connection to the programmable brick. Certain options will be unavailable."

  4. Acknowledge the message. Click "Find Brick", and repeat from #2.

A google search turned up a note about using a terminal emulator to talk to the tower directly. 2400baud, no handshaking, should echo characters in the terminal, and the green activity light should make sense. That DOES work, for both the native port and the USB to serial adapter.
Using https://sourceforge.net/projects/realterm/ on Windows 10, fully up-to-date as of this writing.

  • When I close the native port, the green light comes on and stays on, and remains on while BricxCC tries to connect. It turns off when I reopen the port in the terminal emulator.

  • When I close the USB adapter, the green light turns off, and remains off while BricxCC tries to connect. It stays off when I reopen the port in the terminal emulator, except to indicate activity as expected.

I tried running BricxCC in Compatibility mode for Windows 98/ME, and then for Windows XP (Service Pack 2 & 3). Same result.

Any ideas?

1

A bit more fumbling around led me to an actual installer:
http://bricxcc.sourceforge.net/test_releases

I was hesitant to use that because of the word "test", but in fact that's what's needed to work at all. Download bricxcc_setup_33810_20130220.exe from there and run it, and it "just works".


The situation above came from a zipped archive, not the installer. Having rejected the "test" version, I then found the archive, unzipped it, and tried to use it. Apparently, it was missing something that the installer includes. Comparing the installed program directory to the unzipped one definitely confirms this!

  • I'm glad you figured it out! I was going to suggest going BACK a version, because 3.3.8.9 works alright on my computer. Good to know that 3.3.8.10 works via the installer. – MindS1 Aug 18 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.