I followed the official guide to download microPython and flash it onto an empty MicroSD card (SanDisk Extreme Pro 32GB), but the EV3 screen is now stuck at "Starting" after I insert the MicroSD card. The EV3 works fine without a MicroSD card.

  • Hi Kevin and welcome to Bricks.SE! Can you please provide a link to this official guide you mentioned? That way it would be easier to talk about what steps were already completed, which might contribute to the problem and what should you do next.
    – zovits
    Mar 19, 2020 at 13:48
  • @zovits Sure :) education.lego.com/en-au/support/mindstorms-ev3/python-for-ev3
    – Kevin
    Mar 19, 2020 at 14:02
  • So from your question I gather that you have an empty SD card within the spec (32GB, Class A1), downloaded the EV3 MicroPython micro SD card image from the linked site, flashed it using Etcher on Win10 or Mac, and now, after inserting it into the EV3 in the correct orientation, the brick does not boot. Is all of that correct?
    – zovits
    Mar 19, 2020 at 14:12
  • @zovits Yes, and the brick keep sticking at Starting.
    – Kevin
    Mar 19, 2020 at 14:16
  • Thanks for the clarification, I have edited the provided information into the question, so that others with an EV3 would have an easier time answering it.
    – zovits
    Mar 19, 2020 at 14:32

2 Answers 2


This could be due to a bad SD card or due to bad flashing software. For example, there was a broken version of the Etcher software in early 2019 that caused the same symptoms [1].

  • 1
    Thank you and problem solved. Same reason as it was stated in Github.
    – Kevin
    Mar 19, 2020 at 17:45

I want to add that I encountered the same problem today with Etcher version 1.18.11. I tried to flash the image on my SD card 4 times with this version. Each time Etcher validation failed, and when I tried the SD card in my EV3 the screen stuck at "Starting".

Then I installed Etcher version 1.5.26 and flashed again: validation was successfull this time, and the EV3 booted correctly with the SD card.

So the solution of using version 1.5.26 (https://github.com/balena-io/etcher/releases/tag/v1.5.26) is still valid.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.