Battery box on my LEGO train 60198 is flashing green and orange, then after few seconds it suddenly turns off itself.

I've tried resetting it by pushing the button on the train until it turns purple, but then straight away it starts flashing orange again. After that it turns off itself.

Please explain what is wrong with it.

  • I got same issue as above. Changed all 10 batts (Remote and hub) in to Energizer max - and still same thing. Blinks Green (1x) and Orange (2x). Blinking is only at Hub. Remote is ok. Measured batts (if the voltage is ok - measured 1,54 to 1,64 V at 1,5 measuring routine) - should be ok. Once it rides - it makes like 2-3 meters, than simply power-off (Without White blinking). Any suggestions?
    – Adam
    Dec 25, 2020 at 9:44
  • @Adam Welcome to Bricks.SE! I've added an answer with a few suggestions that might help when you know the batteries are good: bricks.stackexchange.com/a/15698/708
    – jncraton
    Dec 25, 2020 at 15:45
  • Same issue - TL;DR; Some Rechargeable batteries don't give out enough power.
    – Paul
    Mar 10, 2022 at 9:40

3 Answers 3


LEGO guide shows the orange blinking appears when batteries are flat.

enter image description here.

Have you tried using fresh batteries in your train?

  • Yes, all The batteries are new
    – user15039
    Apr 3, 2020 at 18:57
  • I found following meaning for blinking colors: Purple: network has been erased (or hub is waiting for new firmware) Orange: low battery So purple means your controller and battery box are no longer paired and this doesn't effect your issue. However if you still see orange color blinking there seems to be low batteries somewhere (either controller or battery box/hub). I would suggest taking out ALL batteries from both controller as well as battery box/hub and changing to fresh batteries. Try not to mix and match different different brands.
    – Alex
    Apr 4, 2020 at 10:56
  • 1
    Your batteries should also be non rechargeable ones. Rechargeable ones might give a too low voltage even when fully charged (about 7.2 V instead of the expected 9V). If you are certain that the batteries are not the issue, you could contact lego support, they will issue you replacement parts... Sep 24, 2020 at 20:16
  • @MichaelVerschaeve does this come from experience? Because TLG is fine with rechargeable batteries and the following is included in instructions for 60198 under "Important information about batteries": "Rechargeable batteries must be recharged using the correct battery charger under the supervision of an adult. You cannot recharge batteries while they are still in the product, and you must never try to do so. Never attempt to recharge non-rechargeable batteries."
    – Alex
    Sep 25, 2020 at 15:20
  • @Alex, the 7.2V I'm certain, and also sure that for EV3's rechargeable batteries were detected too fast as empty so I'm assuming this might be the case for boost as well.There was a trick however, you could insert a paperclip in a hole for the EV3 to let it know you were using rechargable batteries. This hole was also pinned when using the lego battery that came with the educational versions of EV3. I do not know of such trick with boost. Sep 25, 2020 at 15:54

I had exactly same issue with same model.

The battery box HUB NO. 4 was blinking green (colour of connection) and orange.
I changed to brand new batteries.
Still the hub was blinking green (colour of connection) and orange.

As they mention above it's due to the batteries is out.

What I like to add and to highlight is that there is x6 batteries to change.
LEGO - Powered Up troubleshooting - Changing batteries

Changing the batteries in your LEGO® Power Functions Train

  1. Remove the LEGO Power Functions Battery Box from the train.
  2. Remove the two screws on the bottom of the battery box.
  3. Replace all six batteries with fresh, high quality AAA alkaline batteries.

We don't recommend mixing brands or old and new batteries.

LEGO - Building instructions for 60198 - Book 3 pdf
See page 9 instruction 2.
enter image description here

In my case I been to lazy and didn't check any instruction.
I only open the box, change the 3 batteries I saw and mount it back.
After changing all of the x6 batteries issue solved.


Here are a few other suggestions for folks that are still struggling with this issue or something similar after putting in new batteries.

  1. Pair the hub with your phone and update it to the latest firmware using the Powered Up app if you haven't already done so.
  2. Try controlling the hub using your phone. This will help to isolate the problem to either the remote or the hub.
  3. Pull the batteries out of both devices and just let them sit for a couple of minutes and then put the batteries back in.
  4. Contact customer service. This obviously doesn't help much with Christmas morning strife, but if your hub is indeed faulty, TLG will be happy to replace it at no cost.

Not the answer you're looking for? Browse other questions tagged or ask your own question.