Weird problem here.

My son has had the 60197 train for about a year and I decided to try out the powered-up app for the first time today.

After what seemed to be some kind of software update, which took about 2 minutes, the app connected, but did nothing.

When I went back to use the remote that came with the train, the remote now only moves the train at maximum speed.

To make matters worse, stop does not work, instead pressing the forward or backward buttons on the remote always do the following:

First press: full speed forwards

Second press: full speed backwards

Third press: stop

...Which pretty much renders it unusable as full speed is rather unstable.

Also, channel B is now no longer working.

Has anyone else ever seen anything like this?

I have replaced the batteries in both units and have uninstalled the app and even tried with my phone off just in case something is interfering with the connection.

We are stumped!

2 Answers 2


Hmm, very strange. 🤔 We cannot solve this, so you should contact Lego's customer service at https://lego.com/service and they will give you a replacement for free. They occasionally make oopsies with their technical components every now and then, and I've had a similar problem with the Boost 17101 hub lacking connection under common circumstances.

Also, you've asked another question:

Has anyone else ever seen anything like this?

Yes, I've seen such problems before. I already said that my Boost hub has had unintentional connection issues. One person has had EV3 port power issues, and on Eurobricks some other person is also having a malfunctioning hub. Once again, Lego occasionally makes these technical mistakes every now and then.

  • Thanks for answering, I’ve sent a mail to Lego and I’ll post on here when I get an update from them. Commented Jun 6, 2020 at 16:12
  • 1
    Not sure if you could say LEGO always has issues like that - they would go bankrupt or stop releasing items like that all. Occasionally - sure, always - definitely not. Similar issues have happened with previous generation - Power Functions - elements as well. It is not uncommon for electronics to misbehave.
    – Alex
    Commented Jun 6, 2020 at 19:14
  • Thank you @Alex I've edited my answer now. Commented Jun 6, 2020 at 19:23

I thought I’d update you on the situation for anyone else in a similar position.

I got in touch with Lego via email, it took a while for them to get back due to the COVID-19 pandemic, which is totally understandable.

I received a bright breezy fun reply from someone called Ryan who said he would send me replacement battery box and remote. Once I received these items, the train worked for about an hour and then stopped working.

After troubleshooting, I found that the connecting wire must have had a break near or inside the connector. I contacted Lego again, and they sent me a replacement set of motorised wheels.

They asked me to send back the faulty items using a supplied label.

Absolutely awesome service from Lego.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.