6

So I've recently dug up my old Lego Mindstorms RIS 2.0 (RCX) and have spent the past few days trying to install it into my Windows 7 laptop. It worked fine, except it could not find the correct drivers for the IR tower. Installing it on a Windows XP Virtual machine has given the same result.

Any suggestions/patches?

  • 1
    Do you also have a PC with a Linux install? That is how I'm using my old RCX 2.0. If you do I'll put up an answer with the Linux info. – pcantin Aug 26 '12 at 12:55
  • USB or traditional serial? I assume the former, but both were common in the rcx days. – user3971 Jul 20 '16 at 12:52
7

I have the RCX IR tower setup and working on my Windows 7 laptop. I downloaded the drivers from the ROBOTC.net site here (labeled 'RCX Device driver')

Direct file download link

Note: I am running Windows 7 32-bit, according to the ROBOTC site, this driver is 32.bit only and

No known 64-bit driver is available for the RCX.

0

I searched for this problem as well and want to share my solution with you.

I am on Windows 10 64 bit and had no driver.

So I did these easy steps:

  1. Go to Device Manager and select the USB TOwer
  2. Go to Driver/ Update Driver
  3. Select: Search on this Computer -> Select out of a list on this Computer
  4. Pick the LEGO MINDSTORMS NXT Firmware Update Mode -> Install

Hope I could help someone with this.

  • 1
    Phillip can you explain better ? Where "LEGO MINDSTORMS NXT Firmware Update Mode" comes from ? I don't have such folder/driver neither by installing mindstorm sdk, thanks for clarification – Marcoexo Jul 19 '16 at 15:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.