So I've recently dug up my old Lego Mindstorms RIS 2.0 (RCX) and have spent the past few days trying to install it into my Windows 7 laptop. It worked fine, except it could not find the correct drivers for the IR tower. Installing it on a Windows XP Virtual machine has given the same result.

Any suggestions/patches?

  • 2
    Do you also have a PC with a Linux install? That is how I'm using my old RCX 2.0. If you do I'll put up an answer with the Linux info.
    – pcantin
    Commented Aug 26, 2012 at 12:55
  • USB or traditional serial? I assume the former, but both were common in the rcx days.
    – user3971
    Commented Jul 20, 2016 at 12:52

5 Answers 5


I have the RCX IR tower setup and working on my Windows 7 laptop. I downloaded the drivers from the ROBOTC.net site here (labeled 'RCX Device driver')

Direct file download link

Note: I am running Windows 7 32-bit, according to the ROBOTC site, this driver is 32.bit only and

No known 64-bit driver is available for the RCX.


Please note as of 2022 the accepted answer NO LONGER WORKS (RobotC.net no longer hosts this file). An equivalent tower driver can still be found from here: https://www.philohome.com/sdk25/sdk25.htm

As with before, the USB IR Tower will only work on 32-bit Windows (and also Linux, though that's a different question). If you run 64-bit Windows you will need to:

a) Run the Mindstorms software in a Windows XP virtual machine, OR
b) Get a Serial Port version of the IR tower and a USB to Serial adapter.


If you’re attempting to use the USB RCX 2.0 on Windows 7, 64 bit OS, I used the free version of Oracle VM VirtualBox. I installed Windows XP. In the settings section of the VM software for the XP machine, go to the USB tab, add the USB IR tower (by clicking on the unlabeled “+ add filter” icon on the right side of the page (note: your host OS will not have access to any ‘filtered’ items you add, so don’t add your keyboard or mouse..!). Windows XP should see the IR tower after you begin the XP machine again.

Thanks MindS1 for edit!

  • The NI-VISA method you described is not necessary with the Virtualbox VM. When using the virtual machine, the USB Tower bypasses the host OS entirely. Additionally, NI-VISA seems to only work with the original Robolab programming software and is not compatible with the official Lego software or any other 3rd-party solutions.
    – MindS1
    Commented Aug 19, 2019 at 17:00

I searched for this problem as well and want to share my solution with you.

I am on Windows 10 64 bit and had no driver.

So I did these easy steps:

  1. Go to Device Manager and select the USB TOwer
  2. Go to Driver/ Update Driver
  3. Select: Search on this Computer -> Select out of a list on this Computer
  4. Pick the LEGO MINDSTORMS NXT Firmware Update Mode -> Install

Hope I could help someone with this.

  • 1
    Phillip can you explain better ? Where "LEGO MINDSTORMS NXT Firmware Update Mode" comes from ? I don't have such folder/driver neither by installing mindstorm sdk, thanks for clarification
    – Marcoexo
    Commented Jul 19, 2016 at 15:20

The LEGO Mindstorms NXT driver has the same vendor ID (vid) but not the same PID. When you modify the .inf file and deactivate the driver signature, the driver is well installed, but tower is not able to communicate with leJOS driver found here:


  • 1
    URL links to forum which requires registration, so no information could be reached. Basically this is pointless as URL does not provide any additional details. If there is relevant information please post it into answer directly.
    – Alex
    Commented Sep 7, 2022 at 5:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.