4

I bought a used 8881 battery box. It doesn't appear to work with anything. When I test it with a multimeter, I only get a voltage reading of ~0.5V.

I tested each of the batteries, they each come out ~1.6V (as I'd expect from a AA battery).

It may be that I'm not using the multimeter as intended, and that both the lights and the motor I'm using to test this are broken, but it seems more likely that there's a problem with the battery box.

Any thoughts on what the problem might be?

4

In case anyone else has this issue - cleaning corrosion off of the connections solved the problem!

To clean the contacts, I used white vinegar applied with a cotton-swab/cue-tip. I dried it off with a dry one, left it for about half an hour, and after that it worked perfectly. I watched this video to be sure there wasn't anything I needed to do that I was missing.

3
  • 2
    Yes, leaked batteries did this I presume. I think I've cleaned about half a dozen over the years. In the past, this battery box was very common, so easily and cheaply replaced if the contacts were too corroded, however with the power functions phased out recently, they are getting more expensive Apr 6 at 16:12
  • 1
    @MichaelVerschaeve Definitely looks like corrosion from old batteries. Power functions seems like a much simpler system which I why I went with it, plus powered up stuff seems a little overpriced to me, maybe I'm just not familiar with the kind of prices to expect :) Apr 6 at 21:41
  • 1
    @Criggie Added now - thanks for the pointer Apr 6 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.