So far, on three devices (Amazon Fire tab, Galaxy tab S2, Galaxy Phone S9), the following when trying to connect to the move hub from the Boost app:

  • all three permissions (Bluetooth, microphone, location)
  • upon request by the app, I push the green button
  • then, on the phone, the light on the move hub flashes white, then shines blue - at the same time, the app still shows the prompt to push the green button, the gear symbol in the upper right corner flashes blue
  • on the tablets, the android device shows a waiting screen (cute robot on treadmill), then again the prompt to push the green button

What I've tried:

  • removing and reinstalling the batteries from the move hub
  • as per a guide somewhere on the internet: turning off Bluetooth in the Android device, then push green button on move hub, then allow Bluetooth from within the boost app
  • Installing the Boost app on a PC, however LEGO does no longer support the Windows app & AFAIK no Android emulator handles the Bluetooth connection (nox doesn't, I tried)

What else can I try?

2 Answers 2


I know this is long in the past, but I just had success today with being unable to connect from a tablet which had previously worked fine.

At some point, the tablet had been upgraded (by accidentally tapping the wrong button) and that seemed to be the only possible cause.

(To add more useful keywords for others searching, I'll include what I searched for: I would get the treadmill, then the "Power On the Move Hub" message, then treadmill, then "Power On", then it seemed to just give up. The light on the Hub would turn on (blue), and the distance sensor would light up, but that was all. Another, newer, tablet would loop between treadmill and "Power On" roughly an infinite number of times.)

What finally worked to reconnect the original tablet was:

  • wait until the Boost app prompts to power on the Move Hub
  • extra-long hold the power button until the LED flashes red and/or green
  • when the app asks to upgrade the firmware, do it

I got the information from "SvenO" on EuroBricks

  • 1
    Life saviour ! Thanks !! I struggled for hours... Dec 4, 2021 at 17:51
  • 1
    worked for me!!
    – mart
    Jan 31, 2022 at 16:50

Bluetooth problems are solved by the LEGO® POWERED UP program. After this program establishes communication,the LEGO Boost app will work as well.

  • Nope. In my case Lego Boost refused to connect even though Powered Up was working fine (I could even control the device from Powered Up). In my case, the problem was that I let my 8 year old son start the Lego Boost app, and he probably didn't give the app the requested permissions (bluetooth, microphone, location), so I had to uninstall the app and re-install it to get everything right from the start. Still, the Boost app is terrible, the connection is lost every few minutes for no apparent reason causing both my son and me a lot of frustration! Jan 21 at 15:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.