6

I've recovered my old lego duplo set from the attic, and tried to get the electric train working again. After inserting fully charged batteries, the train does start, but it's unable to pull even a single wagon.

I've also tried using Duracell batteries, but that gives the same result. I've already opened up the train and my dad says he can see a little crack in one of the gears, but the train still runs when using Hameg PS and even with the batteries.

Can I get this thing working again somehow?

Here is a video of the train with a single wagon

Edit

I tried hooking up power.

And at first it started to drive smoother, but after like 5 seconds it got to a halt again. When lifting the train, the wheels spin again, but when putting it down again it just stops. The wires are not in the way for sure.

Here is the video of the train wired to the power.

Currents are:

  • 75 mA while driving
  • 120 mA when stuck

Duplo train wired to power source

5
  • 4
    Hi Pieterjan, and welcome to Bricks! Does it also fail to pull a wagon when using the Hameg PS as well? From the sound in that video, I'd hazard a guess that there's a an issue with the clutch mechanism - to reduce the chance of damaging either the motor or small train drivers fingers the wheels have a clutch mechanism to stop them turning if there's something blocking them. Have you seen this question on stripping down the drive wheels? Sep 29 at 8:26
  • 3
    Hi, thanks for the response. I did try your suggestion, and updated the question.
    – Pieterjan
    Sep 29 at 12:32
  • Can you get a good look at the battery contacts? Corrosion (especially from leaked batteries) can cause a high resistance. OTOH from the video, the motor is still turning, so it's getting power and we're looking for a mechanical fault. If you turn it on upside down, do the wheels turn? How easy are they to stop with a finger, and does this stop the motor noise?
    – Chris H
    Sep 30 at 11:37
  • Thanks. Upside-down the wheels are able to turn but still with the clicking noise twice a second. Gently pushing against the wheels doesn't stop them from turning yet, but pushing slightly harder does block the wheels. The clicking noise still persists though
    – Pieterjan
    Sep 30 at 12:01
  • And I would consider buying a new train set, but that would render the special tracks useless. Although this is probably the only part that will not be usable...
    – Pieterjan
    Sep 30 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.