3

I have installed mindstorms ris 2.0 on an XP system. Initially it worked fine now I get an “insufficient memory” error. I have reinstalled and tried a different hard drive. No change. Possibly the usb tower is plugged into a different port, should this matter? Any ideas?

2
  • I honestly feel really bad you're having so much trouble getting this working for your grandson. I have a classroom set of Robotics Invention System kits I still use to teach robotics, and it's really frustrating the hoops we have to jump through to get the software working on even semi-modern hardware. Kudos to you for sticking to it!
    – MindS1
    Mar 2, 2022 at 14:37
  • Thanks for that. I started out teaching this back in 99 had a classroom set that worked well also used Dacta, which I still have an interface but want to get two copies of Mindstorms working first.
    – Jotec
    Mar 2, 2022 at 16:36

2 Answers 2

4

In response to the error:

"A critical error has occurred. You may be running out of memory, or you may need to reinstall Robotics Invention System 2.0"  

This is a bug with the Quicktime version (4.0?) installed with Mindstorms. Two possible solutions:

  1. https://wittykeegan.blogspot.com/2011/12/running-lego-mindstorms-ris-20-on-newer.html
  2. https://listserv.jmu.edu/cgi-bin/wa?A3=ind0911&L=VADCFLL-L&E=quoted-printable&P=1799439&B=--0-2097542931-1259040070%3D%3A26632&T=text%2Fhtml;%20charset=utf-8

To summarize:

  1. Delete the following temporary file. You may need to make Hidden Folders visible to see the AppData/Application Data folder:

    Vista/Win7: C:\Users<user>\AppData\Local\Temp\Ris 2.0.mov.#res
    XP: C:\Documents and Settings<user>\Application Data\Temp\Ris 2.0.mov.#res

  2. In some cases Step 1 fixes the problem entirely. Sometimes the file reappears and the error message returns. In this case, it's helpful to have a script which automatically deletes the file and launches Robotics Invention System. Copy the following code into notepad, then save as "LaunchRIS.bat":

@echo off

rem Author: Keegan Witt
rem Description: Deletes temp file that prevents RIS 2.0 from launching correctly on newer versions of Windows then launches RIS 2.0

del "%TEMP%\Ris 2.0.mov.#res"
if %PROCESSOR_ARCHITECTURE% == x86 (
    "%PROGRAMFILES%\LEGO MINDSTORMS\RIS 2.0\LaunchRis2.exe"
) else (
    "%PROGRAMFILES(X86)%\LEGO MINDSTORMS\RIS 2.0\LaunchRis2.exe"
)

Make sure this is saved as a .bat and not a .txt! In notepad's Save-As dialog box, select filetype "All Files" before you type in "LaunchRIS.bat" so it doesn't automatically add the .txt extension.

Double click the script to run it. For convenience, you can make a shortcut to LaunchRIS.bat and use that instead of the default shortcut. You can even change the icon back to the yellow RCX brick by selecting the LaunchRIS2.exe executable in the shortcut properties.

  1. If the problem persists, it's possible you already have a later version of Quicktime installed which is conflicting with the version installed by RIS. Open the add/remove programs menu from the Windows control panel to see what Quicktime versions are on your system. Then do the following:
  • Uninstall all versions of Quicktime
  • Reinstall Quicktime 4 from the RIS installer
  • Reinstall the later version of Quicktime to a different install directory so the two versions can coexist better
5
  • Thanks for that I will try it but I think I have found an easier fix. I have set up another user and it seems to be working on that…….almost, it won’t recognise the usb tower…yet. I am working on that.
    – Jotec
    Mar 2, 2022 at 16:33
  • Possibly try reinstalling the USB tower driver? I know there was at least one revision after RIS 2.0 was released. See here: philohome.com/sdk25/sdk25.htm
    – MindS1
    Mar 2, 2022 at 17:58
  • Thanks for that have downloaded. The working second user has now stoped with the same memory error grrrrrrrr
    – Jotec
    Mar 2, 2022 at 19:00
  • The troublesome temporary file I described above reappears when RIS is launched. Have you tried deleting it yet? You may not even need to go past step 1 to fix this.
    – MindS1
    Mar 2, 2022 at 19:48
  • No temp directory found. I did a file search and that did not find the file. Reinstalled QuickTime from mindstorms and now get an error “QuickTime error detected, please reinstall QuickTime from RIS” tried several times same error. Any other ideas ?
    – Jotec
    Mar 3, 2022 at 15:40
2

Got it working with QuickTime installed from the mindstorms folder. First, though I couldn’t find the files shown above, I did a search for all QuickTime files on C:, there were lots in various directories, and deleted them all! I reinstalled mindstorms, without QuickTime then did a separate install of QT. So far that works. The tower is not working yet but that is next when I have tried starting the computer and MS a few time to ensure the QT error has gone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.