I recently bought a RIS 1.5 with brick 1.0 and serial tower (no CD). I got a cheap USB adapter and installed the RIS 2.0. It worked almost fine for a few days. Everytime I started RIS I had to autoconfigure tower, which used COM2. I had to try two or three times to download programs, but it worked.

Later, I installed Bricxcc and connected as well, although I downloaded no program. I did download the original lego firmware with Bricxcc and since then RIS is not able to connect to the RCX.

I have tried with new batteries, uninstalling Bricxcc and then RIS. Installing RIS again, with reboots in the process. Nothing seems to have changed. I cannot connect.

Any previous experience?

I was thinking about buying an USB tower, but I don´t know if it will work with RCX 1.0.

Thanks for your help

1 Answer 1


You could try with NQC. By default it supports the Serial Tower and you can specify if you are using a USB Tower with -Susb . It works on Windows, Linux and Mac.

The man page (documentation) can be found here or the in pdf format here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.