2

I'm trying to downgrade our Spike Prime Hub from the Spike App v3's firmware to the Spike App v2's firmware. Has anyone been successful? Or does anyone have suggestions on how to flash the firmware to a version that's compatible with Spike App v2.0.8 or v2.0.9?

Context

I upgraded our hub to Spike 3. This is the default recommended behavior through the new v3 app as of December 1st, 2022, as follows.

DO NOT DO THESE STEPS IF YOU NEED YOUR v2 CODE TO WORK WITH YOUR SPIKE PRIME HUB

  • Navigate to Spike App v3 (link above) and notice that there is a new version of the app
  • Select Prime
  • Click Update Hub on the popup
  • Follow the steps to update the firmware for the v3 Spike App

  • After doing so, I realized our existing v2 Spike Prime code would no longer be compatible. There's a different filename extension for the new files (.llsp3 vs .llsp). Eventually, I want to switch to the newer app, but for now, I am trying to get our .llsp code working again.

    Attempted resolution

    enter image description here

    1

    1 Answer 1

    1

    Aha!

    1. Prerequisite for Windows: Use this tool to install a driver. (See tips here.)
    2. Use the https://spikelegacy.legoeducation.com/hubdowngrade/ downgrade tool.
    3. Go back to https://spikelegacy.legoeducation.com/ to reconnect.
    4. Follow the prompts to update the Hub OS one last time.

    Your Answer

    By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

    Not the answer you're looking for? Browse other questions tagged or ask your own question.