2

I tried to test a PF servo motor before building it into something larger to see if it works - it seems it does not. When connecting it to a 59510c01 9V PF Battery Box and toggling the switch of the box, the motor does not move at all but emits a faint beeping sound (about two beeps per second). The axle of the servo motor can be turned manually, so the gears are not jammed or broken in an obvious way. When I do so, the LED on the PF battery box lights up - indicating that the current generated by the motor can travel back via the PF wire, so a wire breakage seems improbable.

When testing with a more elaborate setup, using the PF IR remote, the PF IR receiver, and the PF battery box from a 42065 RC Tracked Racer, the beeping starts as soon as the battery box is switched on. Then sending a signal (it does not matter which direction or which channel: even the unconnected channel gives the exact same result) from the IR remote stops the beeping but refuses to turn the axle of the servo.

At this point, I see several possibilities:

  1. I could contact LEGO (as I bought the PF servo directly from them and haven't used it since), but seeing that it is a retired product, I doubt they could support or replace it. Or could they?

  2. I could try to open up the servo to see if anything is broken or stuck inside, but that seems to have a slim chance of success (if something is broken, I doubt I could replace it if it involves more than soldering or gluing a piece) and I still could not close up the enclosure properly. Or could I?

  3. I could try to get another PF servo motor for over 60€ - but at that price, it is not a purchase I would like to make without excluding other options. Or is it the only sensible solution?

  4. I could get a knock-off PF servo motor for 15€, which is 15€ more than I prefer to give to IP thieves. Or are there no other options?

Has anyone had experience with one or more of the above options and could offer me guidance on what to try next?

4
  • 2
    There is a way to check which elements are available for replacement. Unfortunately, LEGO no longer has PF servo in stock. Do you have rechargeable PF battery box to test with? It has speed regulator, which acts as angle of rotation for servo, if I remember correctly.
    – Alex
    Mar 29 at 6:33
  • @Alex sadly no, I only have a few toggle switch battery boxes.
    – zovits
    Mar 29 at 8:40
  • 1
    When you you power your servo it should auto-center. If it doesn't do that - maybe it doesn't know the position? I found some suggestions that it could be caused by dirty contacts or other contact related issue. There seems to be at least two versions of contact implementation, where one has gaps and the other doesn't. Might consider checking this video and EB post if cleaning contacts make any difference.
    – Alex
    Mar 29 at 20:24
  • @Alex Thanks for the suggestion! My servo does not move at all, but is stuck in the factory standard center position unless an external force (i.e. my hand via an axle) turns it. The first video you linked gave me the idea to try and disassemble it (point 2 in the question), but seeing that it is a brand new (that is, unused, although bought 6 years ago) motor, I figured I should really attempt other, less destructive options first.
    – zovits
    Mar 30 at 14:49

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.