1

So, recently I tried to make my old Lego Mindstorms (RCX) work again with modern hardware to avoid digging up my old PCs each time I want to use it. The USB tower works on true hardware (On a PC with Windows XP 32-bit and the driver updated).

I can set up the IR tower in USB and in COM - since my modern PC doesn't have a COM port, I skipped this option and tried immediately with the USB tower.

I know that the USB tower doesn't work with 64-bit PCs, so I made a virtual machine of a Windows XP 32-bit on a host PC with Windows 11 64-bit. I've read that the USB tower needs a driver update to work with Windows XP so I installed it before plugging in the tower and there came the problem.

Each time I plug in the USB tower, the cursor of my virtual Windows XP freezes, the VM seems frozen but I still can press Windows and interact with the keyboard, so XP is somehow still alive (I have difficulty closing the VM too after that). After that I tried to plug the USB tower directly at the start of the VM (with a USB filter in the settings of the VM), here the VM started up, and I saw the Windows XP loading screen and a black screen appeared right after that.

I don't see if I do something bad, maybe on the host machine the tower requires something?

1
  • Hi Pikafort and welcome to Bricks.SE! I've taken the liberty to copyedit your question to get rid of some typos - please fix any places where my edits might have conflicted with your intent. Meanwhile feel free to check out the tour and read the help center pages to learn more about the community and its rules and customs. Play well!
    – zovits
    Commented Jul 4 at 12:48

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.