I downloaded the new EV3 software from Lego and installed it on Windows 7. The EV3 software runs. I plugged in an NXT using a USB cable. EV3 can edit the memory on the NXT and remove programs/sounds/text files.

I created a program that uses the large motor to spin the B motor 1 rotation at 75% power. The end program block finishes the very small program.

It downloads without complaint. Run it and the NXT complains with "File error!".

Is this a known problem? Is there a fix?

The NXT has firmware 1.05 loaded.

2 Answers 2


I needed to update the firmware. 1.05 was too old. 1.31 works.

Download from: http://mindstorms.lego.com/en-us/support/files/default.aspx#Firmware

I did need to run the old NXT-G software to download the newer firmware. I did not try to download the firmware using EV3.


First off Ev3 and Nxt are different machines. However, it's most likely the firmware. I've just downloaded my firmware for Ev3 and I also tried out a program I made. It downloaded perfectly but when I tried to start it, it said "FILE NAME ERROR", which I believe is similar to your problem. I either recommend re-downloading the firmware or turning the Ev3 or Nxt off then trying it again.

  • I only have an NXT brick. The question concerned using EV3 software to create a program and download the program to an NXT brick. The NXT needed newer firmware.
    – dfrevert
    Commented Oct 17, 2013 at 2:14
  • The NXT won't take programs from the EV3 programming environment!
    – Timtech
    Commented Oct 17, 2013 at 15:12
  • Actually, the NXT does accept programs written in EV3-G. It did require a firmware upgrade.
    – dfrevert
    Commented Oct 22, 2013 at 1:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.