For reasons beyond me, the NXC program MotorControl22.rxe in my NXT has disapeared. So i thought I'd just download it from my computer over to the NXT using NeXTTool.

This is where the trouble begins. Firstly, I have no problems listing the NXT in my devices when connected and turned on. I have also been able to upgrade the firmware twice during my troubleshooting, trying to find a solution. But for some reason, using the NeXTTool, I'm not able to connect. I've tried downloading the file using NeXTTool \COM=usb -download=MotorControl22.rxe and after that tried NeXTTool /COM=usb -listfiles=MotorControl22.rxe with no result.

This made me test just listing anything from the NXT, but even writing NeXTTool /COM=usb -listfiles didn't show anything, even though I have confirmed that there are several programs, sound files etc on the NXT.

  • I'm currently running Windows 8.1 64-bit
  • The driver is libusb-win32
  • I'm running NeXTTool from Windows cmd with admin rights
  • I don't get any error messages upon running the download command
  • This has not been a problem earlier upon installing and verifying that everything works.
  • Flashing a new firmware works just fine when in Update firmware mode using NeXTTool -firmare="firmware.rfw"
  • Bluetooth works too, but upon running the download command, nothing happens.

Has anyone run into this problem before? Anybode have any idea how to simply download a file to the NXT and what might be causing it not to work now?

  • I would tend to try with the regular LEGO software too; if even that fails it may mean your NXT brick itself is defective. If you have the opportunity to test another brick, it's of course even better.
    – Joubarc
    Oct 9, 2013 at 14:54
  • Have you tried downloading the file using BricxCC or NeXT Commander?
    – shea
    Oct 9, 2013 at 21:27
  • I tried NeXT Commander. I was able to get a connection, but downloading always failed. I haven't tried BricxCC.
    – nic
    Oct 11, 2013 at 9:39
  • This is a project for school, and we've only got access to MATLAB to program our NXT with. We haven't received a license for the Lego software or LabView for that matter so I'm a little stuck... or is the Lego software license included in the 9696 pack?
    – nic
    Oct 11, 2013 at 9:41

2 Answers 2


Joubarc's idea would probably be your best bet - try downloading the file to the NXT using the official LEGO software. If this fails, you know something is wrong with your brick. If it works, it's probably a problem with your program. Did anything major happen between the time it would work and the time it wouldn't? If so, this may be the culprit. Trying it on multiple bricks is also another avenue I would suggest. There is an official Mindstorms Help Section on the LEGO Message Boards located here. They have experts who will probably be able to correct your problem.

  • Thanks for the tip, but I'm not sure if I've gotten access to the official LEGO software. Is this maybe included in the 9696 pack? The thing is, this is a school project, where we've only aquired licenses for MATLAB, so I don't even have access to LabView... But how is NeXTTool different from the LEGO software other than it lacking a GUI :P
    – nic
    Oct 11, 2013 at 9:44
  • Oh, I was thinking you got the retail version with NXT-G on a CD-ROM. Well, I suppose they're not too different; it's just I'm not too familiar with NeXTTool, although I do use NeXTScreen a bit.
    – Timtech
    Oct 11, 2013 at 11:06
  • I'm going to mark this as the answer, because I gave the NXT to my teacher, who in turn reset it, and he probably used the official LEGO software to do so. Thanks for your response!
    – nic
    Oct 17, 2013 at 12:21
  • 1
    @cazyius You can reset it without the software... but it won't work until you use the software to put on the new firmware, which you were correct in this aspect - LEGO NXT Firmware has a special encoding that can only be done with the NXT-G environment (which means that you have to get LEGO's help when you make your own firmware).
    – Timtech
    Oct 17, 2013 at 15:10

Procedure as follow, uninstall libusb_win32 driver; not disable activate back NXT fantom driver transfer MotorControl22.rxe with NeXTTool or TransferMotorControlBinaryToNXT.bat execute install-filter-win from directory libusb_win32/bin for USB NXT connection it work for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.