I'm running 6 NXT robots in an introductory class.

Occasionally we've had bricks that would not accept a program and I've reset the brick by pushing the reset button under the battery pack as well as pushing the button under the USB port, experiencing the blank screen and "click..."

Re installing the firmware usually gets them going again. I have one brick that when cleared and reset will accept a download, but when the program is run, port B drives the motor at full speed, and nothing else happens.

I have reset the brick many times, and the problem still exists. I sent a query to LEGO and got a computer generated response that there would be contact in 1-2 days.... nothing after a week, Sent the same query again and got tho same auto response.... still no real contact (after 4 days)

I'm looking for suggestions.

  • "click, click ..." is a sign the firmware has gone bad or has never been installed. So replacing the firmware is the only option. "Port B motor drives at full speed." Does anything else work? LCD panel visible? Can you download programs? Any chance the Port B wiring connection has crossed up wires? If the LCD panel is visible, there are a set of menu options to View the Rotation sensor on Port B. Does that change when the Port B motor is turned by hand?
    – dfrevert
    Dec 6, 2013 at 19:24
  • 2
    Receiving no response from the customer service seems unusal as these guys usually have an excellent track record of helping customers. You may want to try calling them directly using the free number for your country. Let them know that you never received a response to your two queries, this may give them the chance to fix what went wrong there.
    – Joubarc
    Jan 16, 2014 at 8:21
  • I managed to recover a 'clicking' NXT brick using a PC with windows XP and Lego Mindstorm NXT v2.0 just by clicking on Update NXT Firmware .
    – user4133
    Nov 3, 2014 at 21:29

3 Answers 3


I just got an e-mail from LEGO that was the real fix:

  1. Make sure the NXT brick is unplugged from the computer and take the battery or batteries out.

  2. On the fourth battery holder down from the top, there is a black rubber button. Using a paper clip, please press down and hold this black rubber button for at least 20 seconds.

  3. Put the batteries back in and then press the orange button. If the brick makes a clicking noise, this is a good thing.

  4. There is a silver button on the top right connector peg hole on the back (there are 6 on the top and 6 on the bottom). Using the paper clip, please hold this silver button down for at least 20 seconds.

  5. If the brick is clicking, please plug it into the computer and open up the NXT software. Go to 'Tools' then choose 'Update NXT Firmware,' then proceed the update the NXT firmware. If you get the error "Cannot Locate," then please go through the following steps:

  6. With the brick plugged in and clicking, go to your computers device manager. To do so you can search your computer and type in device manager and hit enter.

  7. In the device manager, find the 'Ports (Com & LPT) and click to expand this. You should see something that says 'Bossa' which you will right click and choose 'Update Driver Software.'
  8. In the next window, choose 'Browse my computer for driver software.'
  9. In the following window, choose 'Let me pick from a list of device drivers on my computer.'
  10. Choose the options that says 'NXT' or 'LEGO NXT' (one of the options will say something along those lines) and click 'Next."
  11. Once the update is complete, please open the NXT software and try running the firmware update again. Please note that the NXT brick needs to be clicking the entire time as there is a timeout function on the NXT brick which turns the brick off after a certain amount of time. If the brick is clicking, you know it is on
  • It also seems like you have stolen that "e-mail" thing from another user who has commented on the article used in the other answer below. May 21, 2020 at 11:27
  • Step 2 is not necessary. The black rubber button in the battery compartment detects the rechargeable battery pack, so pressing and holding it does nothing. (The NXT firmware is open-source so you can confirm this for yourself in the code if you have doubts.) Sep 14, 2021 at 19:24

Since you tried reuploading the firwmare without success, it sounds like the brick is indeed defective. You were right to contact the customer service in that case as they should be able to replace it; however it's not normal that they didn't contact you back. You may want to call them directly (you can find the number on the service web page) and let them know that your online queries went unanswered.

Alternatively, if you got Education kits (which seems likely since it's for a class), you may want to contact your reseller first and let them know aoub the issue.

The only other possible thing I could imagine going wrong is that the firmware file is corrupted somehow - this would be consistent with the brick accepting it for download, but then failing to run properly. If you have another brick, you may want to try to send the same firmware to it and see if the problem happens too. Then of course you'd need to make sure you download the latest firmware and try that one - I woudl say it's worth a shot anyway (you could also redownload and compare with your existing file if you want to check it's corrupted or not).


Here's what I think you should do:

  1. Completely disconnect your NXT from the computer (no USB connection).
  2. Remove all external Bluetooth dongles from your computer, and turn Bluetooth off on the computer (just to be sure).
  3. Reboot the computer (this is to make sure no other application is trying to compete for the USB port).
  4. Restart the Mindstorms application (and, if possible, don’t start any other applications).
  5. Remove one battery from the NXT for a couple of seconds, then reinsert it.
  6. Push the NXT reset button firmly for five seconds (make sure you actually press it, and press it for the whole five seconds).
  7. Now (with the NXT clicking and the environment up and running), connect the NXT to the computer via the USB cable. Preferably use a “primary” USB port, one on the computer itself and not on a keyboard or monitor.
  8. On a PC, you can go to the device manager and check to see if the NXT shows up in “Firmware Update Mode” (if not, you may need to uninstall and reinstall the software and drivers).
  9. Update the firmware to 1.03 using the “update firmware” option under the tools menu.

If this does not work, try briefly (one second) pushing the reset button again.

If that still doesn't help matters, try repeating steps 1-9 but using a different USB port on the computer.

If that also doesn’t work, try using a different computer and repeating the entire process.

Source: Clicking Brick Syndrome

  • 1
    Rex implied he tried that multiple times already
    – Joubarc
    Jan 16, 2014 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.