4

I have a LEGO Mindstorms EV3 program that I was working on for a long time but recently and suddenly when I try to download the program the software displays the following message:

"unable to compile some documents for deployment"

Taking into consideration that there are no missing blocks and the sensors ports are adjusted correctly and checked many times. What is the main cause of this and how can this be fixed?

  • that happend to me to but i tried everything but nothing works for all you people out there try deleting the lego mindstorms it self then redownloading it – superlego Apr 6 '17 at 17:47
  • Did you get an error code? Was it zero? Or four? Or was it seven? Please send a screenshot of the error by using WIN + Shift + S and crop out the error, then send it to us. Thanks! – mindstormsboi Apr 5 at 12:28
3

Is that the whole error message or are there more lines to it?

You could always try copying and pasting your project pieces into a new project, hoping that the project file itself got corrupted in some way.

It also might be possible that some of your custom blocks have errors in them.

If none of these work for you, then try to isolate the source of the error - hold control and click on parts of the program, then press Run Selected (looks like play sign with parentheses) to check if the error is still there. If the error goes away after testing a specific block, then it is the source of the error, therefore you should looking into more closely to find the issue.

| improve this answer | |
2

If You are using Custom "My-blocks", try copying their content, deleting the block, then pasting it into another tab and re-make it. Hope I helped :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.