4

I have a LEGO Mindstorms EV3 program that I was working on for a long time but recently and suddenly when I try to download the program the software displays the following message:

"unable to compile some documents for deployment"

Taking into consideration that there are no missing blocks and the sensors ports are adjusted correctly and checked many times. What is the main cause of this and how can this be fixed?

1
  • that happend to me to but i tried everything but nothing works for all you people out there try deleting the lego mindstorms it self then redownloading it
    – superlego
    Apr 6 '17 at 17:47
3

Is that the whole error message or are there more lines to it?

You could always try copying and pasting your project pieces into a new project, maybe the project file itself got corrupted in some way.

It also might be possible that some of your custom blocks have errors in them.

If none of these work for you, then try to isolate the source of the error - hold Ctrl and click on parts of the program, then press Run Selected (looks like play sign with parentheses) to check if the error is still there. If the error goes away after testing a specific block, then it is the source of the error, therefore you should look more closely to find the issue.

0
2

If You are using Custom "My-blocks", try copying their content, deleting the block, then pasting it into another tab and re-make it. Hope I helped :)

0

Create a new MyBlock and delete the old MyBlock.

So, you have to create a new MyBlock with a different name and move all the programming to the new MyBlock. Then delete the old MyBlock and replace the old MyBlock with the new MyBlock. This did work for us.

Not the answer you're looking for? Browse other questions tagged or ask your own question.