2

After successfully connecting our NXT to my Macbook Air and upgrading firmware to 1.31 we built our first robot. We plugged in the motors to ports A, B & C and now we get an Error stating that USB ports have been shut down because a device is drawing too much power. I have tried Reseting NXT and now it is stuck in "clicking mode" I have tried two different computers and three different cables. I also plugged in in through a USB hub all with the same result. I have restarted, Shutdown and restarted, Unplugged and restarted, Reset P-Ram.

1

The clicking mode means that you need to reload the firmware on the NXT (under the Tools menu in the NXT software).

If you still get the overcurrent shutdown using different cables and different computers, then the conclusion has to be that there is something wrong with the NXT itself. The USB port should be drawing little to no current at all since the NXT has its own power source.

It would also be worth contacting LEGO support if you do indeed have a defective NXT.

  • I get the over current shutdown using different computers and cables. I will contact Lego. Thanks – Phillip Funkhouser Oct 5 '14 at 20:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.