2

I tried to execute command (via bt) play tone:

play_tone = '\x0F\x00\x00\x00\x80\x00\x00\x94\x01\x81\x02\x82\xE8\x03\x82\xE8\x03'
# send commands to EV3 via bluetooth
with open('/dev/tty.EV3-SerialPort', 'w', 0) as bt:
    bt.write(play_tone)

or start program “Demo” on EV3 brick

run_demo = '\x30\x00\x00\x00\x80\x08\x00\xC0\x08\x82\x01\x00\x84\x2E\x2E\x2F\x70\x72\x6A\x73\x2F\x42\x72\x6B\x50\x72\x6F\x67\x5F\x53\x41\x56\x45\x2F\x44\x65\x6D\x6F\x2E\x72\x70\x66\x00\x60\x64\x03\x01\x60\x64\x00'

but nothing happens. No error in python script. Wireless connection status (EV3 brick display) show connected during script execution.

OS X 10.9.4, Python 2.7.5, EV3

1

Both of your examples are working for me. In the Bluetooth settings on the EV3, make sure "iPhone/iPad/iPod" is not checked.

  • Unchecking "iPhone/iPad/iPod" do the trick. Thanks a lot! – user4053 Oct 22 '14 at 7:04
  • 1
    Please consider accepting David Lechner's answer if it solved your problem. – Kramii Reinstate Monica Oct 22 '14 at 9:33
  • Hi, as Kramii states, it would be really beneficial for everyone if you can accept Davids answer (click the little check mark below the vote count) - David and you will both get some rep, and other people will know what worked for you :) – Zhaph - Ben Duguid Oct 22 '14 at 9:36
  • Vote up requires 15 reputation... which I do not have – user4053 Oct 23 '14 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.