I have a problem with communication between the tower (it's installed and it's working - green light when communicating by IR ) and a RCX 1.0. It's not downloading .lgo file. I've tried with few versions of this file and it's the same.

Now I'm trying on my PC in ROBOTC. Green light is lighting but RCX doesn't respond. I think it is failed. But manually with built in programs it's working

  • What operating system are you running on your PC? Commented Jan 22, 2015 at 22:54

2 Answers 2


Try to use this (Windows XP x86):

RIS v2.0 software -> http://www.mediafire.com/download/vrg2iajcv4uxkf3

Updated USB Tower drivers -> http://www.philohome.com/sdk25/tower164.zip

Also maybe you have a faulty RCX or IR tower. Try to change the battery of the IR tower.

I recommend the use of the Windows XP x86 (32 bits) for install the RIS v2.0 software. You have to uninstall any QuickTime installed in the PC and install the QuickTime that comes with the RIS v2.0.

  • I've tried with RIS v2.0 - there is a problem with quicktime, I don't know why. Than I.ve tried with ROBOTC for RCX and tower is lighting green when I'm downloading firmware but there is communicate that there is no connection with brick. Maybe I'll try to change battery in tower?? What do you think?? Regards
    – gregory
    Commented Jan 22, 2015 at 8:47
  • You say it says there's some problem with quicktime? You need to make sure you have a version of quicktime between 4.0 and 6.4 installed, otherwise you'll get this error. Commented Jan 22, 2015 at 13:42
  • I've installed RIS v2.0 from cd into my other computer (notebook), withouts any problems, than downloaded and instaled drivers for converter rs 232 to usb. Ris 2.0 is working fine but doesn't see my IR tower (serial). I've changed battery for new one and still nothing.
    – gregory
    Commented Jan 22, 2015 at 14:13

I have the same problem. I don't know why, but if I use only the plug adapter (without batteries inside) it works, communicates in/out with the tower. With batteries, no. In my case I only use this RCX with energy from plug adapter. (windows vista, robolab 2.9.4 , rcx 1.0 - usb tower).

  • Hmm... 🤔 strange. It really works just because you removed batteries?? Commented Apr 19, 2020 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.