7

Here is what I have:

  1. Site licences for Mindstorms Software 1.0 (NXT) and EV3.
  2. An upgrade to Version 2.0 for the NXT
  3. 9 NXT kits
  4. 4 EV3 kits
  5. 2 Renewable Energy Kits and Temperature sensors

My problem is that on the NXT units, the only version of the software which supports the Renewable energy/temperature sensors is 2.1, which does not appear to be an upgrade to 2.0, but is instead a education site licence version like the ones I have for NXT 1.0 and EV3. Without these I cannot access the blocks to use the Renewable Energy kits and temperature sensors unless I use the EV3 kits.

My questions:

  1. Am I right, or is there a way to upgrade 2.0 to 2.1 or 1.0 education to 2.1?
  2. is there a way I just haven't been able to figure out to use these sensors with the 2.0 software?
  3. Is it worth updating all my existing material for the NXT bricks to program them from the EV3 software as well and dealing with the small issues or not?

I have tried contacting distributors, and looking online has only helped me find the appropriate sensor blocks for the EV3 software.

4
  1. You probably don't need it, but the LEGO Education NXT 2.1 Software is still for sale through LEGO Education (at least in the USA). They do not advertise and upgrade price, but it does not hurt to ask.
  2. The Energy Meter blocks are available for download on the LEGO Education website. I went to http://education.lego.com/en-us/downloads and checked the box "Blocks" under "Download Type" and it shows up in the list. It does not say if it is for NXT or EV3 though. Also, I found this for the NXT Temperature sensor.
  3. I would not recommend using the EV3 software for programming the NXTs. There are a number of limitations, such as lack of support for 3rd party sensors and lack of support for Bluetooth. Also, I understand the programs take up much more memory this way.
  • Those blocks only seem to work with version 2.1 - I get an error when I try and use them with 2.0. I will try and provide more details later. – Matthew May 14 '15 at 13:52
  • Can you provide more details about the error... – Alberto Santos May 19 '15 at 19:41
2

I managed to install my license of Mindstorms Edu NXT v2.0 (Windows 7 x64) and the software has Data Logging and the Temperature Sensor Block.

If you have an upgrade from v1.0 to v2.0 at least the Temperature Sensor Block will be available.

  • LME NXT v2.1 is now available for download (Win/Mac) on LEGO Education site. – Alberto Santos Apr 1 '18 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.