2

It's crashing on startup which is really irritating. When debugged with terminal it says this:

Unhandled Exception: System.UnauthorizedAccessException: Access to the path is denied.

[ERROR] FATAL UNHANDLED EXCEPTION: System.UnauthorizedAccessException: Access to the path is denied.

What should I do? I've already tried reinstalling it.

System specs: MacBook Air '11, Late 2010, Mac OS X 10.10.3

Latest version of Mindstorms software

  • Does the error say which path? It may be a read-only file or a directory. – Joker May 21 '15 at 19:07
1

The error is caused by the underlying MS Silverlight runtime. As stated in this stack overflow answer, the error may be caused if

  • the caller does not have the required permission.
  • path is a directory.
  • path specified a read-only file.

Possible ways to find a solution:

Open the Console application and see if the error shows details about which path it cannot access.

Repair file permissions of your partition via Disk Utility application.

Search for Mindstorms EV3 files in your ~/Library/Caches, ~/Library/Application Support and ~/Library/Preferences folder and delete these files (backup files first! or make sure TimeMachine is set up). Normally an application will re-create files located in these folders at start.

2

Updating to iOS to 10.10.5 seems to have solved the problem for me. Hopefully this helps someone else out there.

0

I tried to duplicate this on my 10.10.3 MacBook Air 13. No luck. I did see in the readme file that the minimum resolution is 1024 by 768, and the native resolution of the Air 11 is 1366 by 768.

Try the following if you have not already:

I tried to set my Mac to 720 lines to see if I could get the app to crash, but no luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.