6

I gave my grandson (11 years old) the LEGO 3804 Mindstorms Robotics Invention System 2.0. He built a couple things and when he tried to install software to program what he built, the computer would not accept the download. He is running Windows 10.

As a result he can't really use the system. Are there any suggestions or advice from anyone out there to help. I feel terrible about this.

Thank you for your time and expertise.

1
  • Works for me: 1. Download Oracle Virtual Box 2. Download Microsoft Windows ME (4.90.3000) (OEM Full) 3. Get the stuff to work 4. Last but not least: download the VBE9X drivers and install them in Windows ME
    – martin
    Jan 9 '17 at 11:25
2

That set has an RCX in it, is that right? I have several suggestions for you:

  1. Have you tried running the software/installer file in compatibility mode? I understand this software was designed for Windows 95 or 98. If this is the case, there is an option in Windows to 'run in compatibility mode' by right clicking the .exe file, selecting 'properties' and then under the compatibility section, select whichever operating system the software was originally designed for.

  2. I have found this article which may provide you with a tutorial. I am not personally familiar with the set, but I assume this software will work.

  3. Failing all else, I suggest you try Brixc Command Centre . This uses a derivation of C for programming your robot which, as I understand is not too different from the original Lego software. This is freeware and allows you to program not only the RCX, but other versions of Mindstorms robots if that is of interest. I personally use this all the time with my Mindstorms NXT sets and it works a treat. It's a great way to introduce programming to people as well!

Hope these suggestions are of help!

1

I found I could not get the Mindstorms NXT 2.0 software to load on my Windows 10 PC because LEGO revoked the security certificates and wants you to run the newest software. The latest version of Mindstorm software (EV3) seems to load and run a Mindstorms NXT 2.0, however, you lose the remote control via Bluetooth and the ability to update NXT Firmware on the brick if you use the latest. If one has a real need to load the software on Windows 10, I found a method to do so.

  1. Activate the Administrator account on your Windows 10. I found the only method that worked for me was to Search for from windows menu "Computer Management" and run this.
  2. Open the folder Users, and double-click the Administrator account.
  3. Uncheck the option for Account Is Disabled, and click OK or Apply.
  4. Exit Computer management
  5. Click the windows button and select "Switch User" from arrow button on shutdown
  6. Click to enter Admin account
  7. Start Powershell as an administrator
  8. In Powershell, type, D:Setup.ext where D: is the location of the mindstorms NXT 2.0 Setup file.
  9. When you are done, it would be wise to re-hide the administrator account to avoid someone accidentally going into it and causing damage to Windows.

I needed this because our NXT system has some special 3rd party sensors that drivers exist for NXT 2.0 only.

As with any bypassing of windows security features, be wise about how you make use of this approach and touch nothing more than is noted. There are plenty of "how to activate administrator" account help pages but nobody seems to note that Powershell run under the administrator account allows you to load software with revoked certificates. Never load anything you are not 100% sure is truly safe to run with an approach like this. You could load potentially dangerous software if it is not verified as safe. I hope this saves someone the frustration and days of time I spent figuring this out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.