1

I completely built the Mindstorms EV3 Spik3r. Missions 1-4 worked fine. However, with mission 5, and using the pre-made program, the robot just keeps backing up, instead of facing the bug, shooting it and then moving towards it. I put the 'bug' right in front (5cm) of the robot, and it backs up. I put the bug a bit further (50cm) in front, and the robot still just keeps backing up.

If I hold the bug in my hand and move it to about 5 cm from the sensor, above it (like a 45 degree angle), then the sensor detects the bug and the robot shoots at it and then tries to crush it. But it seems pretty flaky.

Is there an ev3 program I could download to help me debug this, or at least understand what's going on? Perhaps a program that shows the ultrasonic sensor's reading in real time on the brick so I can move the bug around and see what the readings are?

What else could I try?

1

Perhaps a program that shows the ultrasonic sensor's reading in real time on the brick so I can move the bug around and see what the readings are?

You can easily view the ultrasonic sensors readings in real time. To do so, turn on your EV3 brick, navigate to the 'Brick Apps' tab (second from the right) and launch the 'Port View' application.

Use the EV3 buttons to find the port which your ultrasonic sensor is connected to. The ultrasonic sensor value should be shown.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.