I am working on a Mindstorms NXT project. Due to annoying bug (cannot find terminal hotpoint thingy) I can't delete a specific block, and if I do so, part of the program will be cut off from the main sequence. I deleted that block and the bug happened, and not knowing what happened, I saved it. I reopened it to find out that part of the program was cut from the main sequence and I tried searching the whole empty space but wasn't able to find it.

enter image description here

Is there any way of retrieving the lost blocks (other than searching) since the file size is still the same, meaning the lost blocks are just lying around somewhere.

2 Answers 2


I have had this problem in the past, and have not been able to find a solution, other than program it with the software meant for programming EV3s, as it is backward compatible (except that Bluetooth doesn't work, so that may be a problem as your photo shows Bluetooth blocks). Hope this helps!


Unfortunately, it's difficult/impossible to fix your program once the bug has occurred. You'll have to recreate the program from scratch (i.e. delete the file and start over).

There are a few ways to avoid this going forward:

  • Save often. If the bug happens, DON'T overwrite your file! Revert to the previous save.
  • Don't resize the white LEGO liftarm thing manually unless you have to. Always let the software decide the spacing between your blocks.
  • Make sure you're using the latest version of the software (NXT-G 2.0). Download it here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.