2

I have a Mindstorms NXT brick, and when switching it on recently, it just started clicking. I have tried many different ways to fix it, but nothing has worked. I've done a soft reset, hard reset (many times), plugged it into my windows machines, it doesn't get recognised.

I suspect the issue arises from using it a few weeks back with a raspberry pi. It normally shouldn't be an issue, but I've read on other forums that sometimes using it with things like raspberry pi or Arduino can cause conflicts in the firmware.

But neither my raspberry pi or Windows 7 machine will recognise the NXT brick any more. Any ideas?

Thanks, Stephen

  • I've tried all of those things. Pt simply, windows is not recognising the brick at all. I've plugged it into computers that it's worked with before, and computers than have never had it plugged into it, with and without the NXT software. I think I've tried all combinations of options. – Sokratees9 Nov 24 '15 at 2:32
  • On the Raspberry Pi (or other Linux computer), if you have the NXT connected (and the NXT is on and clicking), in a terminal, run lsusb. What is the output of this command. If the NXT is not listed there, what is the output of dmesg | tail? – David Lechner Nov 24 '15 at 15:50
  • Thanks for the replies. I tried that already, and got a blank. I've tried a couple of USB cables, and can now only surmise that the issue might lie with the USB port on the brick. – Sokratees9 Nov 24 '15 at 15:52
2

I successfully did a CPR on the NXT CPU, which was 'bricked' by the 'clicking brick syndrome' after updating the firmware of the NXT 2.0 to 1.31

The USB connection was lost and the PC (Win7 64bit) installed an incorrect driver for the NXT USB connection. If found the solution here: https://www.reddit.com/r/FTC/comments/1vvwq9/for_those_who_have_or_have_had_a_clicking_nxt/

After I installed the correct NXT drivers and when I connected the (clicking) NXT I had no connection to the internet and it was recognized as NXT again. I could install the (latest) firmware via the original NXT software. After that I can use the EV3 software as well with my NXT (USB only, no bluetooth)

Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.