3

My 11 year old just spent her entire Christmas Day assembling the Mindstorm EV3 Reptar, but when we put batteries in the brain nothing happened. It didn't turn on, no lights, no sign of power at all. We made sure the batteries were in correctly but still no luck. Does it need to be replaced or are we doing something wrong? Help!

2

If you are 100% sure that the batteries are in the correct direction and the batteries are brand-new, unplug all of the cables from the EV3 brick and try again to make sure they could not be causing a short circuit. If it still doesn't now power up, contact LEGO customer support.

In the US, you will be directed as follows...

We have a dedicated Tech Support team for MINDSTORMS products. They can troubleshoot the problem and either resolve the issue or help you to get a replacement part. Tech Support can be reached at 1-877-680-2800 from Monday through Friday, 7:30am - 5:30pm CST.

1
  • 1
    Thank you! Yes, we unplugged all the cables and still no power. Lego store has reluctantly agreed to trade out the brain for us so we don't have to wait for support or shipping of a new brain. That goes a long way when you're dealing with the disappointment of an 11 year old ;-) Happy holidays. – shirley Dec 26 '15 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.