3

Sorry, I am brand new to Mindstorms and a bit overwhelmed. I bought an NXT robot over Christmas and am confused what software I should install. I installed the EV3 software. The bluetooth doesn't work, but the USB does. The sound sensor and object sensor don't appear. Also it says I have to do a firmware update, but it says I can't do it with the EV3 software.

Is the open source software better?

2

You can try installing the NXT 2.0 software. (See this question)

Here is a working link for the software: http://service.lego.com/en-us/HelpTopics/default.aspx?questionID=2655. Look for "How can I get a replacement for the LEGO® MINDSTORMS® NXT software for set 8547?"

It says that it will not install on OS X 10.10, however, I did successfully install it on 10.10 anyway. I have not tried installing it or running it on OS X 10.11 though.

There are open source alternatives, but the ones I have seen haven't been updated for a long time, so they may have problems running on newer versions of OS X as well.

  • I was able to get that to install, but it just kept locking up. If I update the firmware will it work with the EV3 software? – Tom Rossi Jan 9 '16 at 20:58
  • If you update the firmware on the NXT, it will work with the EV3 software, but with the limitations that you have seen. Bluetooth won't work and some (many?) sensors won't work. The latest version of NXT firmware is 1.31, so if your NXT already has that version, then just ignore the message about upgrading firmware. – David Lechner Jan 9 '16 at 22:29
2

It worked for me by installing the 8527 version (for NXT 1.0) on Mac OSX running El Capitan. It kept giving me an error - looked like it has some flash player dependencies. I removed the process it indicated and continued to install. Did so OK. Afterwards, the program runs fine.

  • Restarted the mb pro and checked - the software works OK. – Pradeep Varma Mar 21 '16 at 11:19
  • Can you provide a few more details on which process you removed - sounds like you have a good solution here. Also, can you provide a link to the 8527 version you mention - this will help others find the right software if they stumble upon the same issue. – Phil B. Mar 21 '16 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.