2

screenshot of installation failure screenshot of installed internet plug ins

Hi

This is the first time I've tried to use EV3 software since upgrading to El Capitan. Before then, it worked perfectly.

When I tried to launch the application a message pops up saying it has detected a problem during application launch.

I uninstalled the software, uninstalled the silverlight plug-in.

I installed the latest Silverlight plug-in, see screenshot

I downloaded the EV3 software and tried to install it, but it didn't complete and didn't give much of a useful failed installation message, see screenshot

Interestingly, the silverlight plug-in has now disappeared.

Any advice?

Thanks Rob

  • Did you contact LEGO technical support? Are there any error messages in Console.app? – David Lechner Mar 16 '16 at 18:32
  • I just had the same problem when updating the Education Software from 1.2.2. to 1.3.1. on a Mac with OS10.12.6. Actually the Silverlight Browser Plugin was missing with me, installing Silverlight separately was fixing the problem even though the reinstallation of the Lego Software also stopped and mentioned an unsuccessful installation. But then I could still launch the software and now it is running. Thanks for the tip! – Michael Nov 29 '17 at 15:40
2

I tried several approaches. Uninstalling and installing Silverlight, uninstalling and reinstalling EV3 and none solved anything. It looks like the installer looks for Silverlight and ends in error. Furthermore, launching EV3 resulted in a crash. No matter I reinstalled version 1.0 and started to update it.

El Capitan is very rigorous with plug-ins. First, launch Microsoft Silverlight in the Applications folder. In the Application Storage tab confirm that Enable Application Storage is selected (ticked). Close Silverlight preferences. In Safari, select Safety and confirm that Enable plug-ins is selected. Press Manage Plugins Settings button (or something similar, my computer is localized in Spanish). Confirm that Silverlight plug-in is checked. In the lower right (when visiting other web sites) select Always Allow (I also selected Execute in non safe mode but I do not counsel it) and Apply. enter image description here

Now launch Mindstorms EV3 and should not crash and be the latest version. Mine one is now functional: enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.