2

I have just sent the following inquiry to Lego Customer Support:

I aborted a firmware update and now the Intelligent Brick does not get past the "Starting.." message when it is turned on. I followed the instructions at http://www.legoengineering.com/ev3-gone-wrong-what-to-do-when-your-ev3-stops-working/ and I can get the Brick to switch to updating, but the EV3 software on my PC does not see that the Brick is connected via USB cable. Is there anything else I can do? The Brick is new and should be covered by warranty - how would I send it in to exchange it?

I'd appreciate answers to either question.

3

You have done the right thing by contacting Customer Service. They'll be able to help you potentially fix this or replace the part if needed.

I know you said that you already tried this, but I wanted to list the steps for a firmware update here in case others find this question. Here's the exact language from the EV3 user guide:

Forced Firmware Update

If you need to update your firmware manually, follow the steps below. (Note: the EV3 Brick still requires a USB connection to your computer)

  1. Make sure your EV3 Brick is turned off.
  2. Hold down the Back, Center, and Right buttons on the EV3 Brick.
  3. When the screen says “Updating”, release the buttons.

If the manual firmware update does not make your EV3 Brick work the first time, repeat the manual update process.

Here are some general things to try if you haven't already:

  1. Take out the EV3 battery and unplug from your computer and just let the brick sit for 30 seconds or so. Repeat the above steps.
  2. Reboot your computer, or try using another computer, and repeat the above steps.
  3. Try using another USB cable and/or USB port and repeat the above steps. This is unlikely to help in your case since the cable just worked for you, but it could be helpful to someone else.

Please post back here if Customer Service is able to provide a fix for this issue, as I'm sure it will help out someone else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.