I’m unable to pair the ev3 brick to our iPad mini. Both see each other but I keep getting this error on the ipad, Connection Unsuccessful, make sure ev3 is turned on and in range. And the ev3 shows a screen...enter image description here

WiFi I turned off on both and on the ev3 Bluetooth is turned on along with visibility. I’ve played around with checking and unchecking iPod/iPad/ etc box.

They paired before but we were experiencing inconsistencies with the brick while running programs and it was advised to try updating the brick so I did and now they are not pairing.

What should I do?

3 Answers 3


I was experiencing similar problem with my Windows PC and EV3 brick.

Restart bluetooth on both, PC/Mac and EV3.

Do NOT pair from the brick. Begin pairing from the EV3 Mindstorm App on your PC/Mac.

It should pair and work as expected.

  • This answer does not help. I upgraded and downgraded my firmware, tried, ipad toggle, restarted, it shows the wifi symbol but shows NONE in connections
    – technazi
    Commented Jul 20, 2018 at 18:29
  • I tried with Bluetooth. Haven't used wifi so can't comment
    – avck
    Commented Jul 21, 2018 at 12:05
  • Pairing from the device helps. If you paired before, remove the bluetooth pairing.
    – Matthias M
    Commented Dec 29, 2018 at 22:07
  • Wireless connection on the EV3 is such garbage, this morning it took me over half an hour to pair the thing with both wi-fi and bluetooth to no avail. In fact, it was so hard that I received all sorts of error variations, to the point where the brick CRASHED when searching networks for the fifth time. I needed wireless because it was too hard to stick the big wire into the brick which was barricaded by other mechanisms, but after all the work I just wished I didn't do it in the first place. No, seriously, never use wireless. If the first try doesn't work then don't even bother fixing it. Commented Mar 9, 2021 at 12:35

I'm experiencing this kind of problem a lot recently.

What helps me when I'm completely stuck: Re-Install the newest firmware (1.09H/E/D).

After this update restart the EV3, close all Apps (shut them down, not switching to Home) and try the connection again.

This helps me in most cases.


I was running into a similar issue - iPad and EV3 could see each other, but got the "Connection unsuccessful..." error message.

The EV3 and iPad had paired previously, and then I updated the EV3 firmware. To resolve the issue, I went to the iPad's Settings->Bluetooth and found the EV3 brick listed.

I clicked on the information icon (blue i in a circle) and chose "Forget This Device". I was able to then repair from inside the EV3 app.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.