3

Yesterday I had the basic driving robot with two large motors, but I could not get both motors running at the same time. I had the tank control programming block, with both motors set to 50% and when running the program both motors would start and one would continue spinning, but the other would stop after only 1 or 2 degrees of rotation.

First I thought it was a problem with the motor, so I replaced it with another motor from another set, but the problem remained. When I switched the ports it was the other motor that would not keep running. I tried different ports, changing the cables and restarting the brick but nothing helped. Checked the rechargeable battery to see if it was a power issue, but that was full. I did this in a class with several other EV3 sets using both large motors and none of the others had this problem.

I then used the programming block for a single large motor and tried both separately and that worked fine. But when I put two of those blocks after each other to start the motors sequentially again the second would not run after an initial click.

When I wanted to troubleshoot it further after I got home everything worked fine, which makes it even stranger. That also suggests it was not the battery box as mentioned in this post.

So I hope maybe someone has seen this before and can tell me why this happened and what to do should it happen again.

Thanks!

EDIT: I found the faulty EV3 (it was number 9, not number 6....). So I was able to do more troubleshooting. Attached a screenshot of the various programs I tried with comments.

It looks like port C is consuming more power than the other ports (motor runs at a significantly higher rpm). And this shuts down any motor running at the same time through one of the other ports. combining two of the other ports (e.g. A and D) works fine.

Any thoughts on how this can happen?

enter image description here

Program

  • Hi jboss and welcome to Bricks.SE! Can you post a screenshot of your program, so that we can see what exactly is happening? – zovits Dec 19 '19 at 9:10
  • I'm not 100% sure it was like this (it was yesterday and everything is removed and taken apart again) but it was the basic driving robot. – jboss Dec 19 '19 at 11:34
  • Maybe try another battery pack? – Alexander O'Mara Dec 19 '19 at 18:42
  • I tried another battery pack, no effect. I also tried resetting the brick, no effect. But when I used motor control from the menu on the brick itself I could run both B and C simultaneously. – jboss Dec 20 '19 at 8:35
  • And another possible cause, I updated the firmware of the brick, but that also made no difference. – jboss Dec 20 '19 at 8:46
1

In the mean time Lego has confirmed that the brick was broken and replaced it.

| improve this answer | |
  • Did this resolve an issue with driving motors as well? – Alex May 26 at 11:58
  • Cheers for the update jboss, glad you were able to get to the bottom of it, and LEGO replaced the faulty item. – Zhaph - Ben Duguid May 27 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.