1

My son is facing an issue with his Mindstorms EV3. Every time he turns it on a low battery alarm is displayed and it shut downs.

This happens regardless of the batteries, we have tried 12 different rechargeable batteries and 6 brand new alkaline batteries.

Also, I noticed it takes a lot to start up, I don't remember it being so slow before.

The sequence is something like:

  • Starting up: it takes 26 seconds
  • Green light: it is on for 2.5 seconds
  • Orange light with low battery alarm: it is on for 8 seconds
  • Shut down: then it shuts down and it takes 20 seconds to complete

I have tried disconnecting every cable, and even opened it up and disconnected the display flex cable, but still the same behaviour. I have double checked the button in the battery compartment to make sure it is not stuck or anything similar, to avoid the brick thinking the Lego battery pack is in place.

Given that it stays on for such a short time frame, I am not able to update the firmware.

I have seen similar posts but none with a solution other than returning the brick to Lego, which is not an option to us given it is no longer under warranty.

Any clues or help?

Thanks!

1
  • Are you totally sure you can't do anything with the firmware? I once found a... well, bug, where interrupting and/or interfering with the update process can cause the EV3 to actually have no firmware at all (except for the startup screen, which remains forever)! I'm not sure how exactly to reproduce it, and I recall that recovering my brick was quite a challenge, but there's a chance that this might help you. I can experiment more with my brick later. – mindstormsboi Nov 7 '20 at 17:06
5

Update: we made it work, after trying many things, see below.

  1. Opened the brick and inspected it for obvious signs of problems but saw nothing. Even tried with the screen disconnected.

  2. We tried, as suggested in the comment above, with a firmware update. Even though the brick will stay on for only a few seconds, it was enough for the computer to recognize it and see were able to begin the update. It completed without problem, showing that the batteries were ok. After restarting it behaved in the same way. We tried firmware 1.09 and 1.10.

  3. We tried ev3dev, from an SD card. It will also shutdown once it finished booting. But after many tries, it booted and displayed the main ev3dev menu, on which we could see the voltage being 5.10, getting lower gradually until it reached 4.60 and it shutdown.

  4. It seemed obvious it was a hardware issue so we decided to desolder the battery contacts and inspect the board properly. There must be something in the circuit sensing voltage, maybe a resistor going bad and being unable to divide voltage properly. We immediately saw the sign of acid going through the board, with that green/blue colour. We cleaned it with a wire brush, resoldered and it worked! Both the brick's firmware and ev3dev worked perfectly, now seeing 9.10 volts.

I hope this helps someone else with the same problem.

Cheers

2
  • Hi Ati, and welcome to Bricks - many thanks for coming back and updating us on your progress :) If you are also "Atilio" you can request that the CM team merge your account so that you can then also accept your answer. – Zhaph - Ben Duguid Nov 11 '20 at 11:16
  • Well I bought a used EV3 unit, described as needing repair and this is my issue. Corrosion inside the unit and on the board. Not sure which part you cleaned with a wirebrush as the tiny components are easily destroyed. One resistor fell off a sensor circuit while I tried to clean the board. On putting it back together same issue, so now it's a pity call to Lego... Not hoping for much! – BoilingFrog Nov 14 '20 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.